InSSIDer stops USB Network Adapter

I installed a USB network adapter to improve WiFi performance of PC workstation. (The tower is on the floor in a corner of plaster walls.)

The device works OK boosting Speedtest scores about 15%.

But…when I launch InSSIDer with this network adapter, it appears that the radio signals are turned off and the internet connection is lost. The symptoms:

  • The green connection-link icon is missing from the Radio pane–next to the MAC of the connected channel
  • The colored signal-level traces in the SIGNAL STRENGTH pane stop and the traces “march” off to the left as time passes.
  • The WiFi icon on the task bar changes to a “globe” icon, indicating “No Internet.”

But the “Connected Devices:…” indicator at the bottom-left of the InSSIDer display continues to indicate connection. (If connected through the internal network adapter–which always stays connected when InSSIDer is running–and the network adapter is manually disabled in the Control Panel, this indicator immediately changes to indicate no connection.)

Am I missing something here?

Hi art.kelly,

Interesting! Do you know if there was another application open that would have started using the resources of the WiFi adapter at that moment in time? Did the adapter get disabled in the network preferences at any point?

For best results, it might be a good idea to only have one adapter enabled and being used in inSSIDer, while any other adapters can remain disabled.

I always have only one (1) network adapter enabled at a time.

I don’t think the in-use adapter became disabled. Will check.

I’m beginning to feel like Melville’s Captain Ahab. I’ve looked too deeply and gone mad.

When I first launch InSSIDer while connected via the external network adapter–the only one enabled–it takes about a minute before the connection is dropped. At that point the external network adapter is still shown as enabled in the Control Panel with 5 bars of signal, but with a big red “X” beside it.

The little WiFi icon in the taskbar is replaced by a “globe” icon.

Later it spontaneously vanished from the Control Panel, and (for the first time) I haven’t been able to bring it back. I’m connected now using the internal network adapter.

I think the external USB network adapter or its driver is flaky and am contacting that vendor.

I’ll chase Moby Dick some more tomorrow…

Hi Art,
Have you tried to TURN OFF automatic (2G/5G) BAND SWITCHING in your modem, router, or adapter - if any?
The network driver may try to find the optimum signal band, even a slower band based on several factors, and will choose a channel on the 2G or 5G side, without telling you.
Also, plaster walls or not, how far away is your computer beyond the plaster wall? The 5G band has very limited penetration and distance strength, if that is what you get set to, and may appear as a “network link lost” situation - in which case you are back to using the computer’s own (garbage quality) internal network adapter
If you turn off auto band switching, you will get two distinct network links, labelled -2G and -5G. Then you can decide which one is more stable, under certain remote distance conditions, and activate that network manually.
HTH,
Joe

Thanks for responding Joe.

Your plan is good and is what I was trying to do. I just wanted to get an antenna up away from the floor and use InSSIDer to find a good antenna location for 5 GHz signal. Then I could disable the 2.4 GHz band and take advantage of the higher bandwidth. In a perfect world, all the WiFi radio antennas would be near the ceiling–no furniture, people, etc. up there to soak up the RF.

InSSIDer and the USB network adapter are just not working together at all to let me do this. I’m pretty sure InSSIDer is working properly and the USB adapter is not. And I like to check in with InSSIDer every day or so to check for intrusions.* The ability to examine the RSSIs of all the radios is just a bonus.

Actually, the last time I launched InSSIDer with the USB adapter connected the whole mess crashed and the USB network adapter just “vanished” from the Network Connections page of the Control Panel.

USB Network Adapter is gone

*I may have had an intrusion a while back–but I was traveling and couldn’t do any investigation–so I had neighbor just turn off the WiFi. When I got back it never showed up again.

So I sent an email to the technical support department of the USB network adapter. This was their suggestion:

​Dear Customer,
Thank you very much for your email requesting information about [the product]

About the issue of the 3rd party that you are using . what we recommend is not to use it . because the wireless adapter is working without it and can free flow for the channel . because the 3rd party SSIDer that you are using is scanning all channels.

Thank you!

Kinda reminds me of the Ring Lardner quote, “Are you lost, Daddy?" I asked tenderly. “Shut up,” he explained.”

HIYAALL,
i have the same issue in Windows 10, v20H,
The Insider disconnects the network card, which is on the supported list, and shows the data of the scan. It seems like the insider is still working, altho the bottom left red text says Connected Devices: No Wifi Adapter, however some times, its showing Starting Wifi Scanner, and just loops endlessly.

What was the outcome of this issue? was the bug resolved?

Thanks for the topic bump up, 4. I have temporarily bypassed the issue because the marginal increase in RSSI with the outboard antenna wasn’t worth the hassle of changing NAs if I wanted to check on what’s connected. My plaster walls must have more transmissivity that I thought…

I am still interested because the next time my attention deficit feature awakens, I want to put an 802.11ax network adapter in the office PC workstation. I’m hoping I don’t hit this InSSIDer issue again with the new NA.

InSSIDer is a really cool application. I guess nobody uses Tektronix 545s any more.

Hi metageek4,

inSSIDer with MetaGeek Plus is designed to only use two WiFi adapters for two different purposes:

  • WiFi scanning - [scan]
  • Packet capture - [packets]

WiFi scanning can happen with just about any adapter on the market and is best left to the internal WiFi card built-in to your laptop.

Packet capture can only be achieved by an adapter from this list here. It is highly recommend to not install any Edimax or third-party drivers for these adapters prior to opening inSSIDer. This is because these drivers can force the adapter to be used as a WiFi scanner [scan] as opposed to a packet capture adapter [packets]. In my experience, these drivers are typically the cause of this issue and the only known resolution is to completely uninstall and delete these drivers from Device Manager to get the adapter in its original state prior to opening inSSIDer.

If you continue to experience problems, please reach out to support@metageek.com and let us know what model of adapter(s) you are using!

Thanks for the response, I did read the requirements of the MG+, and am using one of the supported network cards. Edimax EW-7833UAC.
Just to get my point clearly across,
When I start the Insider+ the windows system manager, starts showing ! on the network card, and the network disconnects. when I close the iNsider + the System manager shows the network card as functional. so the Insider Plus is doing something to the card, that Is not meant to happen.
while the scanning can happen with any network card, the list of clients only shown when using a supported network card, which is what i got.

When you say 3rd party drivers, is Microsoft driver a 3rd party to the Edimax? Or Is Edimax Driver a 3rd party?

The thing is that when installing the Edimax USB in, there is a message to update the driver to ensure that the full speed can be achieved.

Hi metageek4,

The thing is that when installing the Edimax USB in, there is a message to update the driver to ensure that the full speed can be achieved.

I do not recommend installing this driver. We want the adapter to be in its most original state out of the box before using with inSSIDer. This is because inSSIDer will overwrite its own driver across the adapter to turn it into a packet capture adapter. Any driver that is installed prior to that may cause further complications.

When I start the Insider+ the windows system manager, starts showing ! on the network card, and the network disconnects. when I close the iNsider + the System manager shows the network card as functional.

OK, I recommend uninstalling and deleting any previously installed drivers on the Edimax adapter using Device Manager. Once this is done, inSSIDer (ran as admin) should install its own driver across the adapter. It should look something like this: