Cannot run more than 1 802.11ax adapter in Chanalyzer6


I have the Chanalyzer6 running on two 802.11ac USB adapters (Edimax and TPLink) without issues. Since there is now support for the 802.11ax USBB adapters, I got two D-Link DWA-X1850.

I could get Chanalyzer6 to run perfectly well with either one inserted. However, when I have both D-Link DWA-X 1850 adapters connected, Windows will display "There is some problem and we need to collect some information’ when I run Chanalyzer6. After that, the laptop reboots. Tried a few times with single adapter (works) and both adapters (failed and reboot).

I had Device Manager running on another screen and when Chanalyzer6 was reconfiguring the adapters, it reconfigured one of the adapters successfully (CommView next to the adapter) but I guess when it tried to reconfigure the second one, that’s when the problem occurs. Either it cannot accept a second one or it thinks there is a conflict because there is already one reconfigured.

Laptop is running Win 10 Pro ver 10.0.19045 Build 19045. Appreciate some assistance here.