How I fixed my Windows WiFi at home

Originally published at: https://blog.metageek.net/2020/05/how-i-fixed-my-windows-wifi-at-home/

A few years ago, I decided to switch from Mac back to Windows. There’s material for several blog posts behind the reason for the change, as well as the half-dozen times I’ve jumped into and out the Mac/iOS camps, and I won’t get into it here. Suffice it to say that I was pretty happy with my Windows laptop, and HP Spectre something-or-other 13″ convertible (not that I ever use it as a tablet). And then, one day, my WiFi went down the tubes.

I’m not talking about deterioration, I’m talking about “drove off a cliff” grade failure. I couldn’t stay connected, and half the time, I couldn’t even see the SSID for our office network. Rich, our IT guy, and I tried everything we could think of:

  • Have we updated the firmware on our Wi-Fi access points? No.
  • Well, should we? Sure, let’s try it.
  • Did you get a new Wi-Fi driver from Windows Update? No.
  • Well, is there one available? No.
  • How about from the HP driver update app, did you get something there? Yes.
  • Ok, uninstall it, does that help? No.
  • Ok, put it back, is there an even new update? Yes.
  • Oh good, try that, better? Yeah, I think so….no, actually it’s the same.
  • Ok, will you plug this USB Wi-Fi adapter into your only USB port? Um, no.
  • C’mon just try it? Fine, yeah, it seems better. Yeah, it’s better.
  • Great, problem solved! Uh, no dude, I only have one USB port, I’m not giving it up!

It was so bad that I went back to my old MacBook Air as my “meeting laptop” and just left my Spectre at my desk as an under-powered desktop. I had given up on having working Wi-Fi on Windows.

Fast forward a year or so and along comes COVID-19. All of the sudden I find myself working from home and it’s the same story. My Windows laptop is useful for testing, but I have to have it connected to ethernet or an external adapter if I want a reliable network connection. Fortunately, while Ryan was forced to work from home, he turned some of his excess energy loose on a cool new Windows notification-tray app we’re calling InSSIDer Agent (coming soon!).

In order to effectively test InSSIDer Agent, I had to disconnect from ethernet, and after some fiddling around, I was able to get connected to my home Wi-Fi. That’s when the magic happened. Almost immediately I started getting notifications from InSSIDer Agent that my laptop was roaming between two of my mesh nodes, but that all of these notifications indicated that my laptop was using the 2.4 GHz spectrum!

Now, when it comes to Wi-Fi, the only reason to use 2.4 GHz is if there is absolutely no other option. That means if you have a client device that only has 2.4 GHz or are trying to use Wi-Fi at a range beyond what 5 GHz can effectively cover. Neither of those cases applies to my home office, so I FINALLY knew what the problem was.

Even knowing the problem, it took a minute to figure out how to solve it. I found a bunch of settings that seemed related to the problem, but didn’t actually improve it. Finally, I found the silver bullet. Under Network and Internet Settings in the Windows Settings, is an option to Change Adapter Settings.

![](upload://omq9m8but7MO1aZeLmIsZl9HAl1.png)

This setting takes you into the “old school” Windows UI for Networks.

![](upload://uMujUnrLOe46QZ0KAf9VbwTOk3r.png)

From there you can right click on the Wi-Fi interface and choose Properties

![](upload://gURyX4tRAdTB9vB163ZHaoeVk5j.png)

And then hit Configure, to find the magic settings (NOTE: you can also get here from Device Manager)

![](upload://jBK0hOXRf6tq8xyww6uhN0wx5QJ.png)

Now, finally, the magic setting, for me, was selecting 5GHz, 802.11a for the 802.11a/b/g Wireless Mode. This is a bit counter-intuitive, as it deals with the oldest forms of Wi-Fi, and not what is being used on my network, but apparently it is the only way to get my Intel Wireless-AC 8265 adapter to stop using 2.4GHz is to disable 802.11b/g full-stop. Once I did this, my connection has only been on 5GHz. It’s been more stable and faster.

![](upload://sbrMfMHMgspmkI4pRv3WPedsWLi.png)

I’m using Windows as my daily driver, now, I’m not connected to ethernet, and my connection has been rock solid. If you rely on Wi-Fi and you use Windows, I highly recommend making this change to get off 2.4GHz.

Your images did not load so I can’t see what you clicked for Configure. I do see Properties | Advanced | Band that can be set.