InSSIDer won't even launch on Mac

I just registered and downloaded inSSIDer for my Mac. The installation was nice and simple. However, the app won’t run. It crashes on launch. I’m not impressed.

1 Like

I agree- this is happening consistently for me on two mac osx 10.12.6 sierra machines with the following in the crash reporter:
Crashed Thread: 0 tid_307 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[CLLocationManager requestAlwaysAuthorization]: unrecognized selector sent to instance 0x608002626ee0’
abort() called
terminating with uncaught exception of type NSException

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fffad00ab3b __exceptionPreprocess + 171
1 libobjc.A.dylib 0x00007fffc22941da objc_exception_throw + 48
2 CoreFoundation 0x00007fffad08b514 -[NSObject(NSObject) doesNotRecognizeSelector:] + 132
3 CoreFoundation 0x00007fffacf7d703 forwarding + 1059
4 CoreFoundation 0x00007fffacf7d258 _CF_forwarding_prep_0 + 120
5 ??? 0x000000010a0a988e 0x0 + 4463433870
6 inSSIDer 0x00000001027b2603 mono_jit_runtime_invoke + 1571
7 inSSIDer 0x00000001028edd77 mono_runtime_invoke_checked + 135
8 inSSIDer 0x00000001028f6e59 mono_runtime_try_invoke_array + 2313
9 inSSIDer 0x000000010287b852 ves_icall_InternalInvoke + 626
10 ??? 0x0000000103e7e4e2 0x0 + 4360496354
11 ??? 0x0000000108ae75bb 0x0 + 4440618427

Thread 0 Crashed:: tid_307 Dispatch queue:
0 libsystem_kernel.dylib 0x00007fffc2cf7d42 __pthread_kill + 10
1 libsystem_pthread.dylib 0x00007fffc2de5457 pthread_kill + 90
2 libsystem_c.dylib 0x00007fffc2c5d4bb __abort + 140
3 libsystem_c.dylib 0x00007fffc2c5d42f abort + 144
4 libc++abi.dylib 0x00007fffc176294a abort_message + 266
5 libc++abi.dylib 0x00007fffc1787c2f default_terminate_handler() + 267
6 libobjc.A.dylib 0x00007fffc229633e _objc_terminate() + 103
7 libc++abi.dylib 0x00007fffc1784d49 std::__terminate(void (*)()) + 8
8 libc++abi.dylib 0x00007fffc17847be __cxa_throw + 121
9 libobjc.A.dylib 0x00007fffc2294303 objc_exception_throw + 345
10 0x00007fffad08b514 -[NSObject(NSObject) doesNotRecognizeSelector:] + 132
11 0x00007fffacf7d703 forwarding + 1059
12 0x00007fffacf7d258 _CF_forwarding_prep_0 + 120
13 ??? 0x000000010a0a988e 0 + 4463433870
14 com.metageek.inSSIDer 0x00000001027b2603 mono_jit_runtime_invoke + 1571
15 com.metageek.inSSIDer 0x00000001028edd77 mono_runtime_invoke_checked + 135
16 com.metageek.inSSIDer 0x00000001028f6e59 mono_runtime_try_invoke_array + 2313
17 com.metageek.inSSIDer 0x000000010287b852 ves_icall_InternalInvoke + 626
18 ??? 0x0000000103e7e4e2 0 + 4360496354
19 ??? 0x0000000108ae75bb 0 + 4440618427


Unfortunately the beta version of inSSIDer has only been tested on macOS 10.14 or later. You would need to either update to Mojave or Catalina, or purchase a copy of our legacy version of inSSIDer here, which supports older macOS versions.

UPDATE: Our engineering team has released a new beta version of inSSIDer that appears to work with macOS 10.12 and 10.13 (Sierra and High Sierra). It can be downloaded here.


Same problem here. I was forced to upgrade my older version of InSSIDer because it wasn’t compatible with the never version of Mac OS (10.13) but this version won’t run either because I need 10.14. It seems like you have built a product that no one will be able to trust will run for more than a year. :frowning:

@casey - The downloaded file (dmg) cannot be opened.
It fails with “Image not recognized”


Hmm, this image is opening fine on my machine… Can you try downloading the installer here from a different internet browser and see if that helps? For reference, the .DMG file is about 20.6 MB. You will want to make sure your file is this size to ensure the download completed properly.

MD5 (inSSIDer-HighSierra.dmg) = bfce1b637ceef7f7553b49d350481855
inSSIDer-HighSierra.dmg: bzip2 compressed data, block size = 100k

#> hdiutil attach inSSIDer-HighSierra.dmg
hdiutil: attach failed - image not recognized

#> uname -a
Darwin Ilias-MBP 17.7.0 Darwin Kernel Version 17.7.0: Sun Dec 1 19:19:56 PST 2019; root:xnu-4570.71.63~1/RELEASE_X86_64 x86_64

Thanks. This version worked on my macOS High Sierra (v 10.13.6). It would have been nice to see it available (and save hours of putzing) with the other beta download accessed via the inSSIDer page.

I am so sorry about that @rekowsed!
You are totally right, we need to update that page to include this version as well. I will make sure to get that on our list to do very soon.

Hate to tell you that it is still not showing up on your page. Just clicked the only Mac download button and it sent the wrong version.

Thanks for letting me know @ray! I will try to get this updated in the next couple of days

I have updated the download link with a new installer.
This version should work on High Sierra through Catalina.
We don’t have support for Big Sur yet.

Hi Vanessa,
probably you already know but I want to inform that inSSIDer Beta version is correctly working on my macOS Big Sur 11.2.3.
My system is a MacBook Pro (Retina, 15-inch, Mid 2015).



Hi Massimo,

Thank you very much for posting. I forgot to update this topic after our last release.
I am glad to hear that the version is working for you on Big Sur now!


Also working correctly* on my Catalina installation.

(* except for a glitch that I am about to inquire about!).