Channalyzer on Mac M2 Processor

Hi, Ch-analyzers. To run Chanalyer I’ve been using a 2020 MacBook Pro with a Windows virtual-machine inside of Parallels. It’s been great.

I purchased a new Mac with an M2 processor. Windows 11 runs great under Parallels, and Chanalyzer launches and recognizes the WiSpy.

But unfortunately, I have 3 different USB-Wi-Fi adapters and none of them work inside of the ARM-based Windows virtual machine. Windows detects the device as a network adapter but never finds drivers.

Has anyone found a USB WiFi adapter that works with Windows 11 on an Apple silicon M2 chip?

Thanks for any info you may have.

Was there anything special you had to do for Chanelyzer to recognize the WiSpy in Parallels Windows 11? It shows up fine as a device to enable in Parallels but it won’t get recognized when I run Chanelyzer or Tonic.

Hi, Mark. I installed Chanalyzer before I inserted the WiSpy, but that was about it.

You might check your Device Manager while the WiSpy is connected, to see if it appears with a bang (exclamation point). If it does, right-click and uninstall the device from Device Manager, remove the WiSpy from the Parallels auto-connect, then unplug and reconnect the WiSpy and see what happens.

No problems running Chanalyzer, but I still haven’t found a Wi-Fi card that works with Windows on ARM.

Having the same issue on my M1 running windows virtual-machine with parallels 18. Any luck w/ a solution?

Hi, Jeff. It’s been a while since I’ve tried a Wi-Fi card in the Parallels-based Windows. Last time I tried, though, there were still no drivers for Wi-Fi cards in Windows on ARM.